Email Service Degradation
Incident Report for Flo Recruit
Postmortem

Our team has worked with our provider to resolve the issue, as well as apply measures to prevent the same issue from reoccurring in the future. We’ve also manually reviewed and pushed out the undelivered emails that were affected.

Posted Jul 02, 2021 - 14:00 CDT

Resolved
Our engineering team identified an incident where e-mails generated from the Flo Recruit product were not being delivered. Our team has worked with our provider to resolve the issue, as well as apply measures to prevent the same issue from reoccurring in the future. We’ve also manually reviewed and pushed out the undelivered emails that were affected.
Posted Jun 24, 2021 - 16:00 CDT