Issues with logging into the Flo's platform due to AWS outage

Incident Report for Flo Recruit

Resolved

This incident has been resolved.
Posted Oct 20, 2025 - 16:47 CDT

Update

At this time, login pages are active again. We are continuing monitoring at this time.

Please see our status page below for live updates.
Posted Oct 20, 2025 - 14:00 CDT

Update

AWS is still experiencing issues, however we have verified that all video chat interview experiences are working as normal. Admins can still not login to the platform due to the AWS outage - https://health.aws.amazon.com/health/status

We will provide another update in an hour or as soon as more information becomes available.
Posted Oct 20, 2025 - 13:22 CDT

Update

AWS is still experiencing issues, however we have verified that all video chat interview experiences are working as normal. Admins can still not login to the platform due to the AWS outage - https://health.aws.amazon.com/health/status

We will provide another update in an hour or as soon as more information becomes available.
Posted Oct 20, 2025 - 11:53 CDT

Monitoring

We are still seeing issue with the third party vendor (AWS - link below). Customers may still experience delays or errors when trying to log in.

We will provide another update in an hour or as soon as more information becomes available.

https://health.aws.amazon.com/health/status
Posted Oct 20, 2025 - 10:42 CDT

Update

We are still seeing issue with the third party vendor (AWS - link below). Customers may still experience delays or errors when trying to log in.

We will provide another update in an hour or as soon as more information becomes available.

https://health.aws.amazon.com/health/status
Posted Oct 20, 2025 - 09:23 CDT

Update

We are still seeing issue with the third party vendor (AWS). Customers may still experience delays or errors when trying to log-in.

We will provide another update in an hour or as soon as more information becomes available.
Posted Oct 20, 2025 - 08:45 CDT

Identified

We’re currently investigating issues affecting customer logins.
Posted Oct 20, 2025 - 08:35 CDT
This incident affected: Flo Recruit University, Flo Recruit Employer, E-mail Service, and Video Hosting.